Tuesday, 22 September 2009

Gen. Posting Type must be Specified when posting journal entries.

When you try to post a journal entry to selected G/L Account, the following error message prompt up:

Gen. Posting Type must be specified.

This problem occurs because you have specified Gen. Prod. Posting Group for the G/L Account selected. To solve this problem, you can either:
1) Remove the Gen. Product Posting Group from the journal lines
2) Remove the Gen. Product Posting Group from the G/L Account Card and then reselect the G/L Account in Journal lines.


Anonymous said...

Happy New Year!!! pistoles.narod.ru

Andrew and Sue Faber said...

The problem with this solution is that if I remove the GPPG from the account I can no longer post Sales Invoices or Purchase orders that invoice the account.

The other solution of removing it from the journal is very difficult - my journal is an import with hundreds of lines (which are validated and therefore add the GPPG automatically).

The only solution I see is not to validate the G/L account on import but that can lead to bad data going in...

Wolseley said...

An interesting discussion is worth comment. I think that you should write more on this topic, it might not be a taboo subject but generally people are not enough to speak on such topics.

Anonymous said...

Gen.Posting Type must not be in Gen.Journal Line: Journal Template Name=GENERAL,Journal Batch Name=KOJO2,Line No. 3130000

Anonymous said...


I have done Reclasification Journal to transfer from one location to another.

And after adjusting Item-cost entries, when i am trying to post Invenotry cost to g/l it gives me this error.

I am feeling it is bug. Please clarify it.